Save
Saving
  • K
    kubmin

    Hi f.albert!

    I'm running a dev environment with Lay Theme version 2.5.6 in combination with Wordpress version 4.9.7! Hope that helps.

    posted in Bug Reports read more
  • K
    kubmin

    Hi there!

    Using the awesome multilanguage for a website is causing some problems which I cannot seem to fix.

    When creating a simple project with one image and/or text, the website is unable to fetch some json. This happens in either the translated page (i.e from GE to GB) or on the 'original' page (i.e from GB to GE).

    On page load, the console logs:
    invalid desktop json!

    Loading the homepage while on the translated site logs the following:

    GET http://localhost/~user/test/en/wp-json/wp/v2/posts/71 401 (Unauthorized)

    Full json response:

    // http://localhost/~user/test/en/wp-json/wp/v2/posts/41
    
    {
      "code": "rest_forbidden",
      "message": "Sorry, you are not allowed to do that.",
      "data": {
        "status": 401
      }
    }
    

    The not translated homepage logs the same.

    Any idea what's causing this? Thanks.

    Best,
    K


    UPDATE #1:

    I found out that the caption below the image is causing the problems. I guess it has something to do with that piece of text (caption) not having a option to translate. For now, deleting the caption seems to help.


    UPDATE #2:

    Got it, you have to click on the flag that you are editing with the gridder. Add the image and add the caption. After that, click on the other flag and start editing the image caption by double clicking. Edit the caption line (even when you want to have the same text, like names of people, places etc). Click ok. Finally, update/publish the page and voila, it works!

    posted in Bug Reports read more
  • K
    kubmin

    @kubmin fixed... old version of php. sorry!

    posted in Bug Reports read more
  • K
    kubmin

    Hi Armin and Marius,

    I am trying to move a lay theme installation from a development url to the live url.

    The installation has a Instagram plugin installed which is displayed by a shortcode on the 'propaganda' page. On the development url, you can see that the shortcode is working fine and the Instagram feed is being displayed. However, after moving the installation to the live url, the console logs shortcode not found!.

    Any idea what could be causing this? I tried reinstalling the plugin, dropping some tables that are used in the database and even tried installing a random other plugin that works with lay theme and a shortcode, such as Contact Form 7. All the plugins using a shortcode logs the same error to the console.

    I hope I've provided enough info, if you need more I'm happy to help of course :-) And again, thanks for the awesome support & theme.

    Best,
    Kubmin.

    posted in Bug Reports read more
  • K
    kubmin

    Thank you,
    Would love to hear a update on this :)

    posted in Addons read more
  • K
    kubmin

    Hi Marius,

    Thanks for your response!
    This was just an example (I was trying to see if the user was selecting text, if so, cancel the slide tirgger), the issue is that the FullPage function jQuery.fn.fullpage.moveTo(); does not work anymore when the magnetic slides are set to horizontal. Vertically it seems to be working fine.

    Two examples I tried:

    <div class="test"></div>
    
    jQuery(".test").on("click", function(){
      jQuery.fn.fullpage.moveTo(1);
      console.log("clicked");
    });
    

    or:

    jQuery(document).on("click", ".test", function(event) {
    	jQuery.fn.fullpage.moveTo(1);
    	console.log("clicked");
    });
    

    Both of the codes above only works fine when setting the slides to vertically. when the slides are set to horizontal, it does not work anymore. Did something change in the new release or am I doing something wrong? It used to work before.

    Thanks again!
    Kubmin

    posted in Addons read more
  • K
    kubmin

    Hi there!

    Having the same problem, switching 'horizontal' to 'vertical' seems to work with my current code. Horizontal does not work.

    Custom HTML at body:

    <script>
    window.laytheme.on("newpageshown", function(layoutObj, type, obj){
    	if(type == "project"){
    		jQuery(function() {
                var isDragging = false;
                jQuery("p")
                .mousedown(function() {
                    isDragging = false;
                })
                .mousemove(function() {
                    isDragging = true;
                })
                .mouseup(function() {
                    var wasDragging = isDragging;
                    isDragging = false;
                    if (wasDragging) {
                        console.log("MOVE yo");
                        jQuery.fn.fullpage.moveTo(1);
                    }
                });
            });
    	}
    });
    </script>
    

    Any idea what could be causing this? Cheers!

    Best,
    Kubmin

    posted in Addons read more
  • K
    kubmin

    Hi there,

    I am using the Fullscreen Slider plugin and I want visitors to be able to select and copy text from a page using the plugin. Selecting text is super easy, but when a user releases the mouse button (mouseup), it triggers the 'Slide on Page click' and moves to the next slide. This would leave the user not being able to copy the text.

    ISSUE: http://borissmeenk.nl/commonplace/lumiere (second slide, text on the left)

    Any ideas on how to let the user copy the text?

    I tried some stuff like giving the text the class 'text' in combination with this jQuery code (to stay on the same slide ) without any luck:

    window.laytheme.on("newpageshown", function(layoutObj, type, obj){
        jQuery( ".text" ).hover(function() {
            console.log('selecting ...');
            jQuery.fn.fullpage.moveTo(0,0);
        });
    });
    

    Would love to hear your ideas!
    Thanks,

    Boris.

    EDIT: which code sets the 'Slide on page Click' to false? I tried:

    jQuery.fn.fullpage.setAllowScrolling(false);
    

    but that doesn't work.. I think I can write a little hack if I know how to turn on and off the 'Slide on page Click' with jQuery.

    posted in General Discussion read more